[Experimental - Not Loading] Cannot load old save + potential memory leak

Important Spec: 16GB RAM

Directly after patch 0.3.5
2020-08-21-1629-p18996-v1051-S

When I run the game 4GB of memory are used.
When I press “Continue” the usage jumps to 7,9GB and the game.
Now the “save from previous version” popup shows up.
Pressing “Load” increases usage to over 10GB (over 90% usage) but nothing else happens.

The old save does not load.

EDIT:
Tried multiple times now.
Usage:
Startup 900 MB
After Pressing Continue 4,2 GB
After Pressing Load 7,5 GB
After Pressing Continue Again 10 GB
After Pressing Load again 11 GB
After a few seconds 121 MB

For now you can go to the save game directory and manually remove/move your save files

%localappdata%\Titan\

1 Like

Hi @o0Dom0o - there is a very good chance that loading your save in experimental will not work this time around due to the amount of changes we’ve made to ships. If your save file had ships in it I would actually expect it to crash rather than be loaded due to the amount of new things we’ve added to the game. I’ll have a look at your save file if you do upload it, but for now I would suggest starting a new game with experimental. We try our best to allow for old saves to be used, but due to the nature of a game in early access sometimes it’s not always possible for us to guarantee.