Freeze that appears to be caused by roads

Build Number / Patch Number:0.1.16
Seed Number:
Type of Bug: freeze
Blocking Progression: yes
Result of Save/Load: no
Short description:
Built multiple roads in quick succession which cause my game to lock up and become unresponsive.

Reproduction Steps:
Build many roads.

Game save for assistance.
GameData.zip (1.1 MB)

If anyone else has experienced this bug please throw your save games on the pile to help the team locate and fix the cause of the bug.

1 Like

Cheers Mr Q, we might have this fixed in 0.1.17 - let me know!

This / similar still exists in 0.1.17 experimental unfortunately - built a large city in Zen mode and was getting random hangs on building anything next to a road for about 20 mins before a full crash to desktop.

1 Like

@D6_Matt Upload the save if you have it!

1 Like

If you have a save file with the issue reproduceable, it would help us out considerably!

1 Like

Game data folder available here gents, if that’s any help.

https://1drv.ms/u/s!Atod77T8ZxdMo1NWOvX2J6nm98It?e=YdNqWw

It’s the latest one out of that there, wasn’t sure what you needed so dumped the whole folder from today :slight_smile:

1 Like

Sorry, please follow the guide on uploading saves located here. We can’t use the save file unless you have the Titan.met file included (hence asking for the entire gamedata folder :D)

1 Like

Ahh apologies!

Attached :slight_smile:

https://1drv.ms/u/s!Atod77T8ZxdMo1RM5D6V0cwaGBNY?e=4xGgUG

1 Like

Unlisted video showing the freezing issue if you can’t reproduce it - task manager shows all fine.

1 Like

Contributing what I’ve experienced to this thread as well.

Build Number / Patch Number: 2020-06-10-1139-p16401-v268-S (experimental)
Seed Number: 1450360757
Type of Bug: Gameplay / Crash
Blocking Progression: Not immediately, but eventually.
Result of Save/Load: Seems to clear up on a reload for a while and then get bad again.

Description:
Playing Zen mode for about 9-11 simulated hours (3x speed) before I hit my full crash. Here’s what I noticed leading up to that crash:

  • Once I started building my roads, it took a while for workers to start using trucks, then they used them for a short period of time (while my road networks were smaller), and then they stopped using them entirely. All trucks looked stored in the Truck Depot, but and equal amout also appeared to sit idle on the roads.

  • As I expanded further and got to resource nodes and built mines on them, the mineral node in the south functioned properly, with workers retrieving minerals from the mine and moving them to storage. While in the north, my Isotope mine was ignored by workers.

  • First thing I tried was changing the advanced AI to favor mine emptying first then isotope movement second. It didn’t help, but I did notice that my workers were WAY OVERPROVISIONING for mineral movement. 20+ workers for maybe 5 jobs in that category.

  • Then I thought it might be an issue with the roads connecting to the isotope mine, so I demolished them and waited to see if the workers would retrieve the isotopes from the mine. Still no luck. Rebuilt the roads, still nothing. So I ignored that mine and moved on.

  • Eventually I noticed a slowdown in responsiveness for the game, usually when there were lots of idle workers and I tried to build a building or a road. Eventually the game crashed due to memory leak. The straw that broke the camel’s back was a Council monument upgrade.

Ok, so then I reloaded the game, and things just started working again. Workers retrieved isotopes from that mine that was troublesome before, and I kept expanding with a goal to push the limits of the game. I focused on building more roads, and ran into another interesting issue.

When upgrading a command center attached to a road, it suddenly caused a large section of my road network to become ROAD BLOCKED. I submitted a bug report with screenshot at this point, and saved the game. That’s the save I’m attaching to this post.

Save game: https://drive.google.com/file/d/1lQwP71is0l53OGXjx2HJT9DSjhuY8ujy/view?usp=sharing

Debugger_screenshot00003|690x388

I hope this helps isolate the bug! Thanks for all y’all do!

1 Like

Cheers @MattDonatelli for the detailed post! Did you hit send on the crash report dialog that popped up when the game crashed?
Thanks for your save file, very appreciated! I noticed you had two save files attached here - does the other one contain anything pertinent? I’ll have a look regardless :smiley:

@byg_alexa Unfortunately the manner in which it crashed didn’t bring up the crash report dialog. I think this is because it hard-locked and then I quit it via Ctrl+Shift+Escape Task Manager. I’ll try to let it run it’s course next time so I can check the stack traces and such. (I didn’t even know the report dialog was a thing until I saw the “how to” post on the forums.)

2 Likes

Got a similar problem here, each time I built something (e.g. storage facility) attached to a built road the game freezes shortly till there is a big freeze that just ends up crashing the game without report dialog coming up.

I opened up task manager for a few times while the first short freezes appear, everything is fine till the last freeze occurs. The final freeze the game instantly uses 13GB RAM instead of the 2-3GB used before.until the game is ended with no crash message coming up.

Gamedate can be found here: https://gofile.io/d/elAVyX
Made a manual save each time the game freezes shortly for the first time. After crash I started the game, selected “continue” in menu and were able to play along till the short freeze reappears.

2 Likes

Thanks @DaveReed! Will check this out :slight_smile: