Game crash after use  any filter of connected storage 

Build Number / Patch Number: 2020-05-05-0923-p15467–s
Seed Number: 1446475874

Type of Bug: Crash

Blocking Progression: Yes

Result of Save/Load: No

Short description:

Game crash after use any filter of connected storage

Reproduction Steps:

  • loading save

  • open connected storage (filters was default off)

  • try to use any filter

  • Game crashes

[video=youtube_share;Xv9PYxeraTE]https://youtu.be/Xv9PYxeraTE[/video]

game crash so recording also stoped at the end.

[screenshot of the Unreal Engine popup OR copy and paste of the contents of the popup]

LoginId:931c4c6d482ad486568352b86df9e6e3
EpicAccountId:b7c4ade720ae452786cea1c38ede70bc

Unhandled exception

Titan_Win64_Shipping!UBYGStorageDevice::SetCanStor eResourceType() [c:\iot_build\iot	itan\source	itan\world\devices\ storage\bygstoragedevice.cpp:460]
Titan_Win64_Shipping!UBYGUWStorageFullPanel::OnChe ckBoxStateChanged() [c:\iot_build\iot	itan\source	itan\ui\common\enti tyfullpanel\byguwstoragefullpanel.cpp:92]
Titan_Win64_Shipping!UBYGUWStorageFullPanel::execO nCheckBoxStateChanged() [c:\iot_build\iot	itan\source	itan\ui\common\enti tyfullpanel\byguwstoragefullpanel.h:13]
Titan_Win64_Shipping!UFunction::Invoke()
Titan_Win64_Shipping!UObject::ProcessEvent()
Titan_Win64_Shipping!TMulticastScriptDelegate<FWea kObjectPtr>::ProcessMulticastDelegate<UObject>()
Titan_Win64_Shipping!UBYGUWResourcesTable::OnCheck StateChanged() [c:\iot_build\iot	itan\source	itan\ui\common\reso urcestable\byguwresourcestable.cpp:285]
Titan_Win64_Shipping!UBYGUWResourcesTable::execOnC heckStateChanged() [c:\iot_build\iot	itan\source	itan\ui\common\reso urcestable\byguwresourcestable.h:16]
Titan_Win64_Shipping!UFunction::Invoke()
Titan_Win64_Shipping!UObject::ProcessEvent()
Titan_Win64_Shipping!TMulticastScriptDelegate<FWea kObjectPtr>::ProcessMulticastDelegate<UObject>()
Titan_Win64_Shipping!UBYGUWResourcesTableEntry::On CheckStateChanged() [c:\iot_build\iot	itan\source	itan\ui\common\reso urcestable\byguwresourcestableentry.cpp:204]
Titan_Win64_Shipping!UBYGUWResourcesTableEntry::ex ecOnCheckStateChanged() [c:\iot_build\iot	itan\source	itan\ui\common\reso urcestable\byguwresourcestableentry.h:18]
Titan_Win64_Shipping!UFunction::Invoke()
Titan_Win64_Shipping!UObject::ProcessEvent()
Titan_Win64_Shipping!TMulticastScriptDelegate<FWea kObjectPtr>::ProcessMulticastDelegate<UObject>()
Titan_Win64_Shipping!UBYGCheckBox::SlateOnCheckSta teChangedCallback() [c:\iot_build\iot	itan\source	itan\ui\core\widget s\checkbox\bygcheckbox.cpp:147]
Titan_Win64_Shipping!TBaseUObjectMethodDelegateIns tance<0,UBYGMenuAnchor,void __cdecl(bool)>::ExecuteIfSafe() [c:\program files\epic games\ue_4.22\engine\source\runtime\core\public\de legates\delegateinstancesimpl.h:679]
Titan_Win64_Shipping!BYGSCheckBox::OnMouseButtonUp () [c:\iot_build\iot	itan\source	itan\ui\core\widget s\checkbox\bygscheckbox.cpp:196]
Titan_Win64_Shipping!SButton::FArguments::OnClicke d<SWebBrowser>()
Titan_Win64_Shipping!FSlateApplication::RoutePoint erUpEvent()
Titan_Win64_Shipping!FSlateApplication::ProcessMou seButtonUpEvent()
Titan_Win64_Shipping!FSlateApplication::OnMouseUp( )
Titan_Win64_Shipping!FWindowsApplication::ProcessD eferredMessage()
Titan_Win64_Shipping!FWindowsApplication::DeferMes  sage()
Titan_Win64_Shipping!FWindowsApplication::ProcessM essage()
Titan_Win64_Shipping!FWindowsApplication::AppWndPr oc()
user32
user32
Titan_Win64_Shipping!FWindowsPlatformApplicationMi sc::PumpMessages()
Titan_Win64_Shipping!FEngineLoop::Tick()
Titan_Win64_Shipping!GuardedMain()
Titan_Win64_Shipping!GuardedMainWrapper()
Titan_Win64_Shipping!WinMain()
Titan_Win64_Shipping!__scrt_common_main_seh() [d:\agent\_work\1\s\src\vctools\crt\vcstartup\src\s tartup\exe_common.inl:288]
kernel32
ntdll

Hi DarthDevil, thank you for the very detailed report and the video. It’s super helpful for us to see what you were doing at the time! Was this a save you loaded from a previous version of the game?

First time its just happens during play (normal version it was 0.1.10.1, that is my start point ver. ). Then i found experimental version so i run it and it was still happening (0.1.10.5).

and also it was odd for me that filters where off as default.
I also try on the next builded connected storage it was the same.

On the other side now i delete both of connected strorage build two small one upgrade them and then connect and working well