Game Crash + Truck Bugs Regression

Build Number / Patch Number: p21659
Seed Number: 1464913490
Type of Bug: crash bug + truck issue
Blocking Progression: no
Result of Save/Load: no
Short description:

Game crashed though tbh I don’t know what was going on at the time of the crash. However a few behaviors I’ve noticed in thsi save

  • Truck bug seems to have come back. this save I have inconsistent amount of trucks
  • Resource pickup issue at Mon-64. Tried building a Fuel Turbine there
  • Upgraded Transport Hub at Kat-10 has no cars (previous bug regression)

UE4CC-Windows-4128932549435D0B050F8BB1CD4FDA8D_0001.7z (54.8 KB)

GameData.7z (3.1 MB)

LoginId:be6c3514469e6f6d053ddcbf285036a7
EpicAccountId:bfe90ae73bf94ff1b3193f16cb385aa1

Unhandled Exception: EXCEPTION_ACCESS_VIOLATION 0x00000002

Titan_Win64_Shipping!UBYGPowerManagement::CalculateFuelGenerated() [C:\BuildAgent\work\bdc308496d447b55\Titan\Source\Titan\World\Management\BYGPowerManagement.cpp:547]
Titan_Win64_Shipping!UBYGPowerManagement::GameTickMinute() [C:\BuildAgent\work\bdc308496d447b55\Titan\Source\Titan\World\Management\BYGPowerManagement.cpp:507]
Titan_Win64_Shipping!UBYGHeart::Update() [C:\BuildAgent\work\bdc308496d447b55\Titan\Source\Titan\World\BYGHeart.cpp:249]
Titan_Win64_Shipping!ABYGGameState::Tick() [C:\BuildAgent\work\bdc308496d447b55\Titan\Source\Titan\Core\BYGGameState.cpp:105]
Titan_Win64_Shipping!AActor::TickActor()
Titan_Win64_Shipping!FActorTickFunction::ExecuteTick()
Titan_Win64_Shipping!TGraphTask::ExecuteTask()
Titan_Win64_Shipping!FNamedTaskThread::ProcessTasksNamedThread()
Titan_Win64_Shipping!FNamedTaskThread::ProcessTasksUntilQuit()
Titan_Win64_Shipping!FTaskGraphImplementation::WaitUntilTasksComplete()
Titan_Win64_Shipping!FTickTaskSequencer::ReleaseTickGroup()
Titan_Win64_Shipping!FTickTaskManager::RunTickGroup()
Titan_Win64_Shipping!UWorld::Tick()
Titan_Win64_Shipping!UGameEngine::Tick()
Titan_Win64_Shipping!FEngineLoop::Tick()
Titan_Win64_Shipping!GuardedMain()
Titan_Win64_Shipping!GuardedMainWrapper()
Titan_Win64_Shipping!WinMain()
Titan_Win64_Shipping!__scrt_common_main_seh() [d:\agent_work\4\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:288]
kernel32
ntdll

1 Like

Hmm i wasn’t able to reproduce a crash - i noticed there’s one truck missing but i didn’t have any resource pickup issues either… it seems something got reset when the game was saved. I’ll pass this one along, thanks :smiley:

Yeah I coudln’t really reproduce the crash either.

My bigger concern was the regression of the “trucks disappear when you upgrade” bug

1 Like

If a truck is “stuck” used when you upgrade the hub, it’ll invariably disappear :frowning: Any clues as to why your trucks were stuck in used?