Game crashes on startup.

The log from the crash is:

DirectX: Creating window, w=1936, h=1118
DirectX: Initializing
DirectX: Initialized
DirectX: Creating device
DirectX: CreateDevice failed: Unknown error 0x8876086A
STEAM SHUTDOWN
Steam Leaderboards: Destructor

I’ve updated to the latest DirectX and video drivers(and reinstalled both to try to fix this). I’ve noticed that a number of other users in the steam forums have a similar issue, though I’m not sure if the cause is the same as they haven’t provided logs.

I should note that I’m on Windows 7, and as such the latest DirectX available to me is 11, unfortunately. I used to be able to play the game without error on this computer, though, but now I can’t for whatever reason(it’s been a while since I’ve played).

Edit: I forgot to mention my other failed troubleshooting steps–
Tried launching in windowed mode
Tried running as administrator
Tried enabling various compatibility modes
Tried verifying game file integrity
Tried Uninstalling and re-installing fresh
Tried disabling Steam overlay(just in case)
Tried renaming save(just in case)