I cant seem to get my mouse on the menu options to line up. Dont know how better to describe:

i know the screen doesnt show my mouse cursor but its like an inch below the highlighted new game button and i also cant change my resolution because the mouse is off screen on the apply button is to high up for me to click.

Do you have DPI scaling enabled on your OS? I’ve found that generally screws up things in games. You can disable DPI scaling on a per-exe basis, by disabling it on the titan.exe which might help

@mcfury I believe Satoru is right about this one - please consider giving it a shot if you haven’t already!

Mine is doing the same thing on all main menu’s. I turned off DPI for windows and even tried manually setting override for application. Still scales incorrectly.