Out Of Memory

Build Number / Patch Number: 2020-04-17-1241-p14842–s

Seed Number: 1445719156

Type of Bug: Technical

Blocking Progression: Yes

Result of Save/Load: No

Short description:

With the attached savegame the game goes out of memory reliably after less than 5 minutes ingame. For me that is > 21GB of RAM usage which slows everything down to a crawl or stops the game completely.

Reproduction Steps:

  • Load the attached savegame, Continue autosave is fine.

  • See ever increasing memory usage.

I have the exact same problem.
It’s blocking progression and I confirm it’s not the result of save/load from my tests.
I had some context below if it can help, I can provide my game data also if needed.

Reproduction Steps:

  • load the game, everything is ok

  • I do nothing, just wait some time (1~2mn), and at a given point: framerate start to drop even when gameplay is at low speed

  • memory start to increase: constantly take 20~25mb more per second

  • put game on pause, memory leak is also in pause

  • remove the pause, memory continue incresing until out of memory

Context:

  • I started a new game on a version prior to [2020-04-17-1241-p14842–s], no problem, game update to version [2020-04-17-1241-p14842–s], I continued my game with no problem, at some point [4/18/20 7:35PM (Game time: 16h6mn46s)] my game start to have the out of memory bug, tried to do some tests to remove this bug, load a preivous autosave and wait doing nothing, but the out of memory bug arrive at some point

  • I can’t play on this save anymore, so I decided to start a fresh new game on version [2020-04-17-1241-p14842–s], played with no problem until [4/19/20 1:30AM (Game time: 28h3mn33s)] my game start to have the out of memory bug, also tried some tests but the bug happen at some point

  • I have seen that experimental version updated to [2020-04-18-2115-p14908–s], so I tried to load the 2 previous savegames to see if problem is solved, response is no, the out of memory bug also come at some point

Hi billykater and mattai20, this is a known issue that we’re currently working on trying to solve. Would you mind telling me what the specs of your machines are? Thank you for your detailed reports!

Hi Bahar, thanks for your reply, and good to hear that it’s an already known issue and you’re working on it :slight_smile:

My computer is pretty old lol:

  • CPU: Intel® Core™ i7 950 @3.07GHz

  • GPU: NVIDIA GeForce GTX 1060 3GB

  • RAM: 8GB

  • OS version: Windows 7 (64 bits)

  • Motherboard: Gigabyte X58A-UD3R

  • and 2 monitors with resolution 1920x1200

But when I start a fresh new game I have 4GB free of physical RAM (every apps is closed before playing).

Hello,

Same issue for me, just to make sure I played two different games and after a while GPU drops load to 0% with small fluctuations (Gpu ram stays full)-

Ram from normal ~ 6-7 Gbs goes to full 32Gbs and the game music goes on , the game DOES NOT crash but slows down and freezes ( I have to manually close the game from task manager ).

I made sure i have deleted old save files and just left one auto and one manual save in case that had to do something with it and re-loaded but same thing happens again.

Just Purchased ~9 hours ago, game is updated to latest version.

You will find ~ Gamedata ~ folder and ~ Saved ~ folder attached.

Systems Specs:
CPU : AMD Ryzen 7 2700X
MB : Gigabyte Aorus X470 Gaming 7
RAM : 32Gbs Corsair Vengeance 3200Mhz
GPU : Gigabyte 970 GTX G1 Gaming
Storage : Samsung 970 EVO NVMe m.2 500 GB
Monitor : LG 34UM88 34" 3440x1440
OS: Windows 10 Pro (Latest update)


Don’t know if this helps, but I have the same problem and it was a sudden rise in memory usage. Then everything grinded to a halt and I had to kill the process.

Its a memory leak somewhere. I have the same problem with almost every update.

@XtraLars we are working on finding a fix for this issue! Were you able to send your save files through the bug reporter when this occurred? That will hopefully help us find some more of the issues. We’re dedicating a lot of time to figuring out why this is happening, and why it’s not happening on our own machines. Thanks!