PLEASE READ: Windows 7 Users

UPDATE: It’s fixed now!

UPDATE: We have found a temporary fix for those running on Windows 7! Please see Patch 0.2.2 for more details.

Hello Founders! As you may be aware, the recent Unreal Engine upgrade requires DLLs that are not supported on Windows 7, which means that the next Industries of Titan update will not be compatible with computers that are still running on Windows 7.

If you attempt to run the next update from Windows 7, you may run into one of these error messages:

The procedure entry point CreateDXGIFactory 2 could not be located in the dynamic link library

The program can’t start because XINPUT1_4.dll is missing from your computer. Try reinstalling the program to fix this problem.

Our team is currently looking at a couple options for reinstating Windows 7 support in future updates. Unfortunately, we can’t downgrade the engine as a viable solution to this problem, since the upgrade was to fix 2 low-level critical crashes.

While we examine our options and wait for a UE patch from Epic, we have a couple recommendations:

  1. Upgrade to Windows 10. Windows 7 users are able to upgrade to Windows 10 for free (https://www.microsoft.com/en-us/software-download/windows10).
  1. If you do not plan on upgrading from Windows 7, we suggest that you disable auto-updates on the Epic Games Store before the next patch on Tuesday, July 7, so that you can continue to play.

If you have any questions or concerns, please feel free to reach out! We’ll keep you all posted.

2 Likes

Well If I knowed this in the beginning. I wouldn’t buy the game.
Its like throwing money out of a window.

So Is there any way of getting my money back ?

1 Like

Yeah, this ruins Titan for me as well. As far as i know there weren’t any warnings that this game will be win10 only.

Hi folks - I’d encourage you to hop on over to this thread for some more information! We are actively hunting for a solution (this is currently our number one priority). I’ll paste the answers from our Project Lead and Associate Producer here:

Thank you so much for this info and for your commitment to not abandon win 7/8 players. As long as there’s a solid chance for a fix in the future, i don’t see a reason why i should refund now. I’m going to watch this page for news. Thanks again!

2 Likes

We will absolutely let you know when we have a solution! Thank you for your understanding.

I am glad to hear you are working on a fix, I waited for a while for the next update and was very dissapointed when it did not work.
Is there a way we can push Epic to work on it?

Spam them with complaints?

I mean you guys or Epic wanna pay for an upgrade to windows 10, I will take that over a refund!

complaint spamming will just make them hate us, and be less likely to make 4.2.5 work for windows 7/8.

Definitely don’t complain directly to Epic. We appreciate the sentiment, but we’re not at a loss for options to pursue.

In fact, we’re very close to what we think will be a good short-term solution that will get Windows 7 users playing again. We just need to do some more testing to verify the fix.

Thanks for your patience and understanding as we’ve been working on this.

@administrator1 @zorg @Marc_420 @Likes_Are_pointless great news! Patch 0.2.2 just released and you should be able to play again on Windows 7 :smiley:

1 Like

Thanks a lot. Will report back as soon as i can.

Hi folks. I hope this temporary fix helps get you back on your feet and playing the game again.

I just wanted to emphasize that the current solution is a temporary one, and we’ll need to replace it with a more stable fix once we get more information from Epic. You might experience bugs that other players aren’t experiencing in the meantime, but it is still one of our highest priorities to get a more permanent fix in place moving forward.

Thanks for all your help highlighting and testing this issue as community members, it really helps us identify and fix issues.

Well I hope it worked for other people, because it didnt work for me I get the same error.

[screenshot removed for sensitive info]

I did do some googling and tried runing directly from the epigames/industriesoftian/titan/binaries/win64 folder and ran the Titan-Win64-Shipping.exe and got this error

So I googled that and found a XINPUT1_4.dll put it in the windows/system32 folder

Then I get this error, but only if I run it directly from the exe, through the launcher is still the first error.

Well thats were I am stuck for now, I appreciate you guys and gals actually working on the issue.

I sent the same info the Epic’s help center, they told be its a microsoft problem and to contact them.

@Marc_420

Hi Marc, thanks for the report!

IMPORTANT: I’ve removed screenshot #1 from your post because it contained sensitive auth info for your Epic account.

Also important, you probably don’t want to go adding anything to system32 folder on a whim. I’ve seen things online indicating this might help, but it won’t in this case.

Could you try ensuring your Titan folder looks like this?

Run

And try double clicking Titan_NoVendorDevice.bat in order to run the game? (while signed in to EGS)

Let me know if that helps!

Thanks for taking that down, forgot this is public.

Looks like I got no luck tonight…thanks again though.

I also did get rid of the .dll file before trying this

Hello

Thank you for all your hard work guys! Im so glad I can play again on win 7.
i was really sad when i found out the problem as this was looking to be a new favourite game of mine.
the fact that i can now get to playing it is amazing for such a short turn around time!
ive already tested it and it seems to be working as normal…no crazy bugs yet!

2 Likes

Can you try running the batch file as an Admiinstrator?

1 Like

Well holy donkey balls it worked!! I ran the .bat file as admin and It actually loaded up!

Thanks for all the hard work! Go BraceYourselfGames!!

1 Like

Thanks for the suggestion @Satoru!