Storage Bug: We need YOUR information!

Hi there everyone!

We know that many of you are experiencing an issue where the storage in your Global HUD (the top of the screen displaying all your cumulative resources) is not matching what is actually in your storage containers. This has been an issue we’ve run into many times but is very difficult to cause on purpose. Any information about what about your play is causing the bug to happen would be super useful - here are some of the things we’ve been able to figure out with the help of many of the people in Discord. Some things that we have noticed so far:

  • this bug might be caused by using the filters on storage containers to filter certain resources in and out of containers

  • this bug might be caused by dismantling storage containers

  • this bug might be caused by building inaccessible storage containers that Employees store resources in anyways

  • this bug might be caused by cancelling construction of buildings or devices

Please reply to this post if you think you have additional information!

Hello - I first encountered the storage bug when having my employees move resources from mixed storage containers to filtered ones. I started a new save and have not filtered any storage containers. So far have not encountered this bug again. I’ll be testing this on the experimental version shortly.

Have not been able to reproduce on 0.1.1

Edit - have now encountered, just later than previously. See later comment

Chiming in. I too have this problem, and I too have not dismantled any storage, blocked in containers, or used the filtering system.

Currently out of balance by over 100 minerals right now (200 stored in a ‘connected’ storage facility, but only 100 avail to use)

Just encountered on 0.1.1. I built a storage facility and filtered everything out of my existing storage containers. My employees are now moving resources from storage container to storage facility without actually depleting the contaainers

Experiencing a pretty nasty case of this right now; started out with trash receptacles filling up, now it’s escalated to entire storage units stuck in a weird state where things put into them also disappear. Didn’t use filtering before it started happening.

The worst part of this is that broken resources and/or broken storages are completely ignored by Employees and can’t be taken off to Smokestacks to be burnt… which means you need to build more storage, or your colony is going to get overrun by the garbage your Citizens create!

Afflicted savegame has been attached, in the hopes that debug tools might be able to coax some insight out of it. Initially I was wondering if it had something to do with the storage being in a building that’s being upgraded, but that doesn’t seem like it’s the case as one afflicted building (a L1 Storage Facility with 74 trash) has never been upgraded.

I experience a variation of this bug. For me, the displayed counts are the same for my storage containers and top bar, but some resources are unavailable for building/use.
For example: I have a displayed mineral count of 37 (both global and storage container). I order a new factory and workers carry 5 minerals to it, but then idle. My mineral count now shows 32, but they are unable to take any out of storage. If I cancel the job both counts go back up to 37 and I can then use those 5 minerals for other things. But the other 32 remain inaccessible.
My storage containers are filtered, but I believe the mineral storage was never rebuilt (and I am now unable to do so, as it contains resources I can’t access). Several other buildings have been constructed and deconstructed though.
I have tried saving and loading the game and disabling the containers and removing their filters. I might try to do some further testing tomorrow, if no one else finds anything till then.

After some further testing, this is what seems to be happening:
When queuing a build order all resources are subtracted from the global count. Then workers carry them from storage to the build site. If you cancel the process when some resources have been delivered, the NOT already delivered resources are refunded instantly, while the delivered resources are carried back. The instantly refunded resources are now inaccessible.

EDIT: This alone does not yet explain it. I’ve experienced now both diverging numbers between storage and global count as well as inaccessible resources (even over the discrepancy) despite not cancelling builds.

I think I’m onto something with this one now. I decided to look inside my HQ and check on my very first broken waste receptacle, only to find it had a heap of33 minerals in it, putting it at -33 capacity! I checked again a moment later, and that number had gone up to 34, but I didn’t see how it could have.

But then I realize something: I know that in the top corner of the same floor, there’s a Medium Storage, so I go up to check what it contains. And what does it contain? 34 Minerals.

I unpause, let them drop another unit of Minerals into the Medium Storage so that it ticks up to 35, and sure enough the Trash Can ticks up to 35 as well.

Something to do with how resources are stored/handled over the multiple internal floors is weird. This doesn’t explain the Ghost Trash in my external Storage Buildings, but it may explain (or more accurately, indicate that there are) some other issues in how resources are being stored in the game’s memory or something to that effect.

Whoa @Arcalane will look into this!

@Arcalane this might have been the tip we needed to resolve this: thank you so so much. I’ll let you know what happens from here on out!

No problem! I found it pretty much entirely by accident.

If it helps any, the save I provided earlier in this thread has an active case of the particular issue I’m experiencing; zoom into the HQ and on the first floor, select the topmost receptacle underneath the ‘RETURN TO CITY’ button. It should display as containing 33 Minerals and 15 Trash, giving an Available Space of -33. On the second floor directly above it there’s a Large Storage that contains the 33 Minerals. Watch Employees deliver Minerals to the Large Storage and the Minerals value in the Trash Receptacle should tick up as well.

At least one of my 3 saves (I think they all have it) has this issue. See attachment I used for another bug report (freezing game when loading save).
The following does or doesn’t apply to my save games:

  • N/A NO FILTERS - this bug might be caused by using the filters on storage containers to filter certain resources in and out of containers

  • N/A NO Dismantling done - this bug might be caused by dismantling storage containers

  • Applicable Placed a fair amount of physically unreachable containers - this bug might be caused by building inaccessible storage containers that Employees store resources in anyways

  • Partially, not always fully the case in my saves - this bug might be caused by cancelling construction of buildings or devices

I also noticed in one of the saves in a container in HQ that it has a total negative -47 amount (with a total of 150+ items stored in that container). Container is physically unreachable. And is a small storage container. (1X1 size)

I also noticed that if you pause the building while it is set to be built, it adds resources to your stockpile (on the top bar). If you then cancel said building while it is paused, those resources stay there. However, it doesn’t seem to physically add those resources to your actual stock, only shows them in the counter at the top.

I’ve also noticed that, once I try to deconstruct a container, there is no way to cancel said deconstruction. That might be something nice to add.

On the same note, if you disable the container and then re-enable it (in my case specifically waste containers) the resources will show in your HQ / factory information but will not show up on the top bar. The workers also will not move them out of these containers. So I have 3 waste containers in my factory completely filled but the worker refuse to move anything out of them to the Smokestack. The top bar also does not count that waste either. It is as if those containers no longer exist. However, my HQ inventory lists the 45 waste in these containers when I mouse over it. Hopefully this helps to pin down the problem.

I’ve had this, I’ve done all 4 of the points: Filters, dismantling, out of range, etc.

For me the problems start when i try to move storage to outside of the HQ in to a warehouse.

Hello,

I had this problem multiple times: I set a temporary storage. When i no longer need it, in filter i unchecked everything in order the worker to transfer its content to a new location but most of time worked stop to work except for construction and ruins. The rest of time, they are stading there, idle. If i check back at least one ressource in the container filter, most of time workers get back to work.

I just add this problem a few minutes ago and fixed it this way… but my storage can’t be dismantle because it’s not empty.

Hi all, just an update - we’re hoping to push a fix later today that solves at least two of the issues regarding storage (there are multiple). Thanks for all your information, please keep me updated on if this fix prevents any of the issues you’re having.

Dear BYG,

i started a nwe game today with the bug in mind and wanted to check when it first happened. I skipped all tutorials and started building stuff. I think the bug started for me when i build 9 storage containers in a 9x9 field so some could not be accessed.

Here i tried and remove a storage so it would be accessable again but it didnt work. i had a discrepancy of 7 minerals which were stored in the marked storages which were not accessible earlier.

I then filtered all resources out and dismantled the storages. There were minerals left on the floor which couldn’t be removed and i had a discrepancy of 4 minerals

Later i built a Large Storage on the same spot and alls minerals therein were not registered on the global ui but in the local hq ui
Even clearing this storage and move the minerals to another storage would not bring them back. I played this game a little further and the discrepancy between global ui and stored minerals got bigger and bigger. Its kind of frustrating having 500 minerals in storage and just 50 in the global ui to build with :(.

But keep up the good work and hopefully you’ll fix this soon

Seeing similar desync of internal storage vs external/global storage. I know corporate operations can be corrupt, but this is out of hand - whoever’s responsible for taking stock/inventory or auditing the storage values needs to be fired…!

Unfortunately it’s impossible to move to completely external storage as you have to have at least one storage container, but at this point I think it’s safe to say that the global UI is having issues understanding storage inside buildings. ?

Example image;


I’ve ordered my personnel to start moving items out of HQ storage and into the facility, and now they’re going to a Medium Storage with Minerals and magically converting it into… Isotopes?